blob: 940b72d3f421486dae6411be55dce46461ac5b35 [file] [log] [blame]
Patrick Venturec8eec652017-04-10 15:21:32 -07001FILESEXTRAPATHS_append := "${THISDIR}/files:"
Patrick Venturecf534522018-11-06 09:40:06 -08002LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://${QUANTABASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Patrick Venturec8eec652017-04-10 15:21:32 -07004
5inherit systemd
Patrick Venturec8eec652017-04-10 15:21:32 -07006inherit obmc-phosphor-systemd
7
8S = "${WORKDIR}/"
9
10SRC_URI = "file://init_once.sh \
11 file://poweroff.sh \
12 file://poweron.sh \
13 file://host-gpio.service \
14 file://host-poweroff.service \
15 file://host-poweron.service"
16
17DEPENDS = "systemd"
18RDEPENDS_${PN} = "bash"
19
20SYSTEMD_PACKAGES = "${PN}"
21SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
22
23do_install() {
24 install -d ${D}/usr/sbin
25 install -m 0755 ${S}init_once.sh ${D}/${sbindir}/
26 install -m 0755 ${S}poweroff.sh ${D}/${sbindir}/
27 install -m 0755 ${S}poweron.sh ${D}/${sbindir}/
28}