blob: 3e1a6d8acd248bedb7553895cb53e717e63e02f5 [file] [log] [blame]
George Hungde864a92020-07-20 21:02:11 +08001SUMMARY = "OpenBMC Quanta Detect Present Service"
2DESCRIPTION = "OpenBMC Quanta Detect Present Daemon."
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS_${PN} += "bash"
11
12SRC_URI = " file://detect-gpio-present.sh \
13 file://detect-gpio-present.service \
14 "
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m 0755 ${WORKDIR}/detect-gpio-present.sh ${D}${bindir}/
19
20 install -d ${D}${systemd_system_unitdir}
21 install -m 0644 ${WORKDIR}/detect-gpio-present.service ${D}${systemd_system_unitdir}
22}
23
24SYSTEMD_PACKAGES = "${PN}"
25SYSTEMD_SERVICE_${PN} = "detect-gpio-present.service"