George Hung | 4f20ff8 | 2020-05-12 16:56:27 +0800 | [diff] [blame] | 1 | SUMMARY = "Power Cycle by Hotswap Controller" |
| 2 | DESCRIPTION = "Power Cycle by Hotswap Controller Daemon" |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit systemd |
| 8 | |
| 9 | DEPENDS += "systemd" |
| 10 | RDEPENDS_${PN} += "bash" |
| 11 | |
| 12 | SRC_URI = " file://hotswap-power-cycle.service" |
| 13 | |
| 14 | do_install() { |
| 15 | install -d ${D}${systemd_system_unitdir} |
| 16 | install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_system_unitdir} |
| 17 | } |
| 18 | |
| 19 | SYSTEMD_PACKAGES = "${PN}" |
| 20 | SYSTEMD_SERVICE_${PN} = "hotswap-power-cycle.service" |
| 21 | |