blob: ed9c13687438be073212aa7339e947bcc1c17071 [file] [log] [blame]
Tim Leecbb46b92020-06-18 09:28:26 +08001SUMMARY = "Init PSU inventory"
2DESCRIPTION = "Setup PSU inventory read from PSU"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit allarch systemd
8
9RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
10RDEPENDS_${PN} += "bash"
11
12SYSTEMD_SERVICE_${PN} = "first-boot-set-psu@.service"
13SYSTEMD_SERVICE_${PN} += "first-boot-set-psu@0-2-0x58.service"
14
15SRC_URI = "file://${BPN}.sh file://${BPN}@.service"
16
17S = "${WORKDIR}"
18do_install() {
19 install -d ${D}${bindir} ${D}${systemd_system_unitdir}
20 install ${BPN}.sh ${D}${bindir}/
21 install -m 644 ${BPN}@.service ${D}${systemd_system_unitdir}/
22}