George Hung | a8f1a52 | 2020-08-03 13:39:03 +0800 | [diff] [blame] | 1 | PR = "r1" |
| 2 | PV = "1.0+git${SRCPV}" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | SRC_URI = "git://github.com/quanta-bmc/read-margin-temp.git" |
| 7 | SRCREV = "ca2dc1bf7f34d517f0edc59dd3596c3a76c3d7a1" |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit autotools pkgconfig |
| 11 | inherit meson |
| 12 | |
| 13 | DEPENDS += " nlohmann-json" |
| 14 | DEPENDS += " sdbusplus" |
George Hung | a8f1a52 | 2020-08-03 13:39:03 +0800 | [diff] [blame] | 15 | DEPENDS += " sdeventplus" |
| 16 | DEPENDS += " phosphor-dbus-interfaces" |
| 17 | RDEPENDS_${PN} += " bash" |
| 18 | |
| 19 | FILES_${PN} = "${bindir}/read-margin-temp" |
| 20 | |
| 21 | do_install() { |
| 22 | install -d ${D}${bindir} |
| 23 | install -m 0755 read-margin-temp ${D}${bindir} |
| 24 | } |
| 25 | |