George Hung | 85d9f2a | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 1 | PR = "r1" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 4 | |
| 5 | |
| 6 | inherit systemd |
| 7 | inherit obmc-phosphor-systemd |
| 8 | |
| 9 | |
| 10 | SRC_URI = " file://phosphor-ipmi-flash-bmc-verify.service \ |
| 11 | file://bmc-verify.sh \ |
| 12 | file://config-bmc.json \ |
| 13 | " |
| 14 | |
| 15 | FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json" |
| 16 | |
| 17 | DEPENDS += "systemd" |
| 18 | DEPENDS += "phosphor-ipmi-flash" |
| 19 | RDEPENDS_${PN} = "bash" |
| 20 | |
| 21 | do_install() { |
| 22 | install -d ${D}${bindir} |
| 23 | install -m 0755 ${WORKDIR}/bmc-verify.sh ${D}${bindir}/ |
| 24 | |
| 25 | install -d ${D}${systemd_system_unitdir} |
| 26 | install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bmc-verify.service ${D}${systemd_system_unitdir} |
| 27 | |
| 28 | install -d ${D}${datadir}/phosphor-ipmi-flash |
| 29 | install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash |
| 30 | } |
| 31 | |
| 32 | |
| 33 | SYSTEMD_PACKAGES = "${PN}" |
| 34 | SYSTEMD_SERVICE_${PN} = "phosphor-ipmi-flash-bmc-verify.service" |