Patrick Venture | 577d59b | 2017-04-10 15:21:32 -0700 | [diff] [blame] | 1 | FILESEXTRAPATHS_append := "${THISDIR}/files:" |
| 2 | |
| 3 | inherit systemd |
| 4 | inherit obmc-phosphor-license |
| 5 | inherit obmc-phosphor-systemd |
| 6 | |
| 7 | S = "${WORKDIR}/" |
| 8 | |
| 9 | SRC_URI = "file://init_once.sh \ |
| 10 | file://poweroff.sh \ |
| 11 | file://poweron.sh \ |
| 12 | file://host-gpio.service \ |
| 13 | file://host-poweroff.service \ |
| 14 | file://host-poweron.service" |
| 15 | |
| 16 | DEPENDS = "systemd" |
| 17 | RDEPENDS_${PN} = "bash" |
| 18 | |
| 19 | SYSTEMD_PACKAGES = "${PN}" |
| 20 | SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service" |
| 21 | |
| 22 | do_install() { |
| 23 | install -d ${D}/usr/sbin |
| 24 | install -m 0755 ${S}init_once.sh ${D}/${sbindir}/ |
| 25 | install -m 0755 ${S}poweroff.sh ${D}/${sbindir}/ |
| 26 | install -m 0755 ${S}poweron.sh ${D}/${sbindir}/ |
| 27 | } |