Patrick Venture | 136d17f | 2018-04-13 13:41:52 -0700 | [diff] [blame] | 1 | inherit native |
| 2 | inherit obmc-phosphor-license |
| 3 | |
| 4 | DEPENDS += "virtual/phosphor-ipmi-fru-inventory" |
| 5 | PROVIDES += "virtual/phosphor-ipmi-fru-merge-config" |
| 6 | |
| 7 | # Put the fru_config in the right place with the right name. |
| 8 | # Pull the IPMI FRU YAML config to use it in the IPMI HOST YAML. |
| 9 | do_install_append() { |
| 10 | IPMI_FRU_SRC=${datadir}/phosphor-ipmi-fru/config |
| 11 | IPMI_HOST_DEST=${D}${datadir}/phosphor-ipmi-host/config |
| 12 | install -d ${IPMI_HOST_DEST} |
| 13 | cat ${IPMI_FRU_SRC}/config.yaml > ${IPMI_HOST_DEST}/fru_config.yaml |
| 14 | } |