Ed Tanous | 93319c0 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 1 | inherit obmc-phosphor-systemd |
| 2 | inherit useradd |
| 3 | |
| 4 | USERADD_PACKAGES = "${PN}" |
| 5 | |
| 6 | # add a user called httpd for the server to assume |
| 7 | USERADD_PARAM_${PN} = "-r -s /usr/sbin/nologin bmcweb" |
| 8 | |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b" |
| 11 | |
Ed Tanous | d312129 | 2018-03-20 08:42:54 -0700 | [diff] [blame] | 12 | SRC_URI = "git://github.com/openbmc/bmcweb.git" |
Ed Tanous | 93319c0 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 13 | |
| 14 | PV = "1.0+git${SRCPV}" |
Andrew Geissler | b3d6349 | 2018-07-19 10:55:08 -0500 | [diff] [blame] | 15 | SRCREV = "1f2fbf2043495963bcd63da5893718c249e6b194" |
Ed Tanous | 93319c0 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
Ed Tanous | 8d5e4a9 | 2018-06-20 14:22:29 -0700 | [diff] [blame] | 19 | DEPENDS = "openssl zlib boost libpam sdbusplus gtest nlohmann-json libtinyxml2 " |
Ed Tanous | 93319c0 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 20 | |
| 21 | FILES_${PN} += "${datadir}/** " |
| 22 | |
| 23 | inherit cmake |
| 24 | |
Ed Tanous | d312129 | 2018-03-20 08:42:54 -0700 | [diff] [blame] | 25 | EXTRA_OECMAKE = "-DBMCWEB_BUILD_UT=OFF -DYOCTO_DEPENDENCIES=ON" |
Ed Tanous | 93319c0 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 26 | |
Ed Tanous | b5b71a7 | 2018-07-17 10:20:09 -0700 | [diff] [blame] | 27 | SYSTEMD_SERVICE_${PN} += "bmcweb.service bmcweb.socket" |
Ed Tanous | 93319c0 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 28 | |
| 29 | FULL_OPTIMIZATION = "-Os -pipe " |
| 30 | |
| 31 | do_install_append() { |
| 32 | rm -rf ${D}${includedir}/dbus |
| 33 | rm -rf ${D}${libdir}/cmake |
| 34 | } |