| SUMMARY = "Tool to produce a statistics based on a diff" |
| DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \ |
| the insertions, deletions, and modifications per-file. It is useful for \ |
| reviewing large, complex patch files." |
| HOMEPAGE = "http://invisible-island.net/diffstat/" |
| SECTION = "devel" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=5713b4719a66a6527e6301e8f8745877" |
| |
| SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \ |
| file://run-ptest \ |
| file://avoid-check-user-break-cc.patch \ |
| " |
| |
| SRC_URI[sha256sum] = "f54531bbe32e8e0fa461f018b41e3af516b632080172f361f05e50367ecbb69e" |
| |
| inherit autotools gettext ptest |
| |
| EXTRA_AUTORECONF += "--exclude=aclocal" |
| |
| LDFLAGS += "${TOOLCHAIN_OPTIONS}" |
| |
| do_install_ptest() { |
| cp -r ${S}/testing ${D}${PTEST_PATH} |
| } |
| |
| BBCLASSEXTEND = "nativesdk" |