blob: de540db745a6b6c7b4918d955f84e8b5c584762d [file] [log] [blame]
SUMMARY = "Init PSU inventory"
DESCRIPTION = "Setup PSU inventory read from PSU"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
inherit allarch systemd
RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_base-utils}"
RDEPENDS:${PN} += "bash"
SYSTEMD_SERVICE:${PN} = "first-boot-set-psu@.service"
SYSTEMD_SERVICE:${PN} += "first-boot-set-psu@0-2-0x58.service"
SRC_URI = "file://${BPN}.sh file://${BPN}@.service"
S = "${WORKDIR}"
do_install() {
install -d ${D}${bindir} ${D}${systemd_system_unitdir}
install ${BPN}.sh ${D}${bindir}/
install -m 644 ${BPN}@.service ${D}${systemd_system_unitdir}/
}