| # This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org. |
| |
| SUMMARY = "Go programming language compiler (upstream binary for bootstrap)" |
| HOMEPAGE = " http://golang.org/" |
| LICENSE = "BSD-3-Clause" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707" |
| |
| PROVIDES = "go-native" |
| |
| SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}" |
| SRC_URI[go_linux_amd64.sha256sum] = "9a58494e8da722c3aef248c9227b0e9c528c7318309827780f16220998180a0d" |
| SRC_URI[go_linux_arm64.sha256sum] = "a72a0b036beb4193a0214bca3fca4c5d68a38a4ccf098c909f7ce8bf08567c48" |
| |
| UPSTREAM_CHECK_URI = "https://golang.org/dl/" |
| UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux" |
| |
| S = "${WORKDIR}/go" |
| |
| inherit goarch native |
| |
| do_compile() { |
| : |
| } |
| |
| make_wrapper() { |
| rm -f ${D}${bindir}/$1 |
| cat <<END >${D}${bindir}/$1 |
| #!/bin/bash |
| here=\`dirname \$0\` |
| export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}" |
| \$here/../lib/go/bin/$1 "\$@" |
| END |
| chmod +x ${D}${bindir}/$1 |
| } |
| |
| do_install() { |
| find ${S} -depth -type d -name testdata -exec rm -rf {} + |
| |
| install -d ${D}${bindir} ${D}${libdir}/go |
| cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/ |
| |
| for f in ${S}/bin/* |
| do |
| make_wrapper `basename $f` |
| done |
| } |