blob: 6b37e1864ac73c7dedb98e1cdc0127137a389d4e [file] [log] [blame]
SUMMARY = "A toolkit to write, run and analyze benchmarks"
DESCRIPTION = " \
The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
Features: \
* Simple API to run reliable benchmarks \
* Automatically calibrate a benchmark for a time budget. \
* Spawn multiple worker processes. \
* Compute the mean and standard deviation. \
* Detect if a benchmark result seems unstable. \
* JSON format to store benchmark results. \
* Support multiple units: seconds, bytes and integer. \
"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
SRC_URI[sha256sum] = "9752fe749c21e460a564bb3f52fc319b892c62ee61c5138b4a9bbf94ad2755e6"
DEPENDS += "python3-six-native"
PYPI_PACKAGE = "pyperf"
inherit pypi python_setuptools_build_meta
RDEPENDS:${PN} += "python3-misc python3-statistics"