blob: e0e84df28a2574ecc68d922fcd8e76ef8aafaa62 [file] [log] [blame]
SUMMARY = "Run-time type checker for Python"
HOMEPAGE = "https://pypi.org/project/typeguard/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
SRC_URI[sha256sum] = "c556a1b95948230510070ca53fa0341fb0964611bd05d598d87fb52115d65fee"
inherit pypi python_setuptools_build_meta ptest
SRC_URI += " \
file://run-ptest \
"
RDEPENDS:${PN} += " \
python3-core \
python3-compression \
python3-unittest \
python3-typing-extensions \
"
RDEPENDS:${PN}-ptest += " \
python3-pytest \
python3-typing-extensions \
python3-unittest-automake-output \
python3-unixadmin \
python3-mypy \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
DEPENDS += "\
python3-distutils-extra-native \
python3-setuptools-scm-native \
"
BBCLASSEXTEND = "native nativesdk"