| SUMMARY = "Window navigation construction toolkit" |
| LICENSE = "LGPLv2" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| |
| BPN = "libwnck" |
| |
| SECTION = "x11/libs" |
| DEPENDS = "intltool-native gnome-common-native gtk+3 gdk-pixbuf-native libxres" |
| |
| PACKAGECONFIG ??= "startup-notification" |
| PACKAGECONFIG[startup-notification] = "-Dstartup_notification=enabled,-Dstartup_notification=disabled,startup-notification" |
| |
| GNOMEBASEBUILDCLASS = "meson" |
| GTKDOC_MESON_OPTION = "gtk_doc" |
| GIR_MESON_ENABLE_FLAG = 'enabled' |
| GIR_MESON_DISABLE_FLAG = 'disabled' |
| |
| inherit gnomebase gobject-introspection gtk-doc gettext features_check |
| |
| def gnome_verdir(v): |
| return oe.utils.trim_version(v, 1) |
| |
| SRC_URI[archive.sha256sum] = "30cb79a839f90cd66f3e202f3f98cb5166fa0cd9b92eb571ad9c470a43021d83" |
| |
| # libxres means x11 only |
| REQUIRED_DISTRO_FEATURES = "x11" |