blob: fe7ee2e7503c12cd27b542ecb6d8bc6d8af8077c [file] [log] [blame]
SUMMARY = "Service configuration manager daemon to control service properties"
DESCRIPTION = "Daemon controls service properies like port, channels, state etc.."
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
inherit cmake systemd
SRC_URI = "git://github.com/openbmc/service-config-manager"
PV = "0.1+git${SRCPV}"
SRCREV = "ba2c083ebaae5a0e9ba87358f67b620e0345f4b9"
S = "${WORKDIR}/git"
SYSTEMD_SERVICE_${PN} = "srvcfg-manager.service"
DEPENDS += " \
systemd \
sdbusplus \
sdbusplus-native \
phosphor-logging \
boost \
"
RDEPENDS_${PN} += " \
libsystemd \
sdbusplus \
phosphor-logging \
"