blob: c5984f14b21b30995a24a3c648fbbf639aacf0b1 [file] [log] [blame]
SUMMARY = "Phosphor Network IPMI Daemon"
DESCRIPTION = "Daemon to support IPMI protocol over network"
HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
PR = "r1"
PV = "1.0+git${SRCPV}"
inherit autotools pkgconfig
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
DEPENDS += "autoconf-archive-native"
DEPENDS += "phosphor-mapper"
DEPENDS += "systemd"
DEPENDS += "phosphor-ipmi-host"
RDEPENDS_${PN} += "libmapper"
RDEPENDS_${PN} += "libsystemd"
RDEPENDS_${PN} += "iptables"
inherit useradd
USERADD_PACKAGES = "${PN}"
# add ipmi group
GROUPADD_PARAM_${PN} = "ipmi"
SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
SRCREV = "5e452093830644245b83a817b8dad2fdb36ea550"
S = "${WORKDIR}/git"
SYSTEMD_SERVICE_${PN} = " \
${PN}.service \
${PN}.socket \
"