blob: 01f180c8cb40ce83029f7f97a6e55ae9349b199c [file] [log] [blame]
SUMMARY = "Provides the core functionality for pydantic validation and serialization."
DESCRIPTION = "This package provides the core functionality for \
pydantic validation and serialization.\
\
Pydantic-core is currently around 17x faster than pydantic V1."
HOMEPAGE = "https://github.com/pydantic/pydantic-core"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c"
SRC_URI[sha256sum] = "6d30226dfc816dd0fdf120cae611dd2215117e4f9b124af8c60ab9093b6e8e71"
DEPENDS = "python3-maturin-native python3-typing-extensions"
require ${BPN}-crates.inc
inherit pypi cargo-update-recipe-crates python_maturin
S = "${WORKDIR}/pydantic_core-${PV}"
PYPI_ARCHIVE_NAME = "pydantic_core-${PV}.${PYPI_PACKAGE_EXT}"
RDEPENDS:${PN} += "python3-typing-extensions"
INSANE_SKIP:${PN} = "already-stripped"
inherit ptest
SRC_URI += "file://run-ptest"
RDEPENDS:${PN}-ptest += "\
python3-dirty-equals \
python3-hypothesis \
python3-pytest \
python3-pytest-mock \
python3-unittest-automake-output \
"
do_install_ptest() {
cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
rm -rf ${D}${PTEST_PATH}/tests/benchmarks
}