blob: 5b5864c4e7a868a969f02d2b64b5c487797e4167 [file] [log] [blame]
# Copyright (C) 2017 Armin Kuster <akuster808@gmail.com>
# Released under the MIT license (see COPYING.MIT for the terms)
SUMMARY = "Lynis is a free and open source security and auditing tool."
HOMEDIR = "https://cisofy.com/"
LICENSE = "GPL-3.0-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3edd6782854304fd11da4975ab9799c1"
SRC_URI = "https://downloads.cisofy.com/lynis/${BPN}-${PV}.tar.gz \
file://0001-osdetection-add-OpenEmbedded-and-Poky.patch \
"
SRC_URI[sha256sum] = "f394df7d20391fb76e975ae88f3eba1da05ac9c4945e2c7f709326e185e17025"
#UPSTREAM_CHECK = "https://downloads.cisofy.com/lynis"
S = "${WORKDIR}/${BPN}"
inherit autotools-brokensep
do_compile[noexec] = "1"
do_configure[noexec] = "1"
do_install () {
install -d ${D}/${bindir}
install -d ${D}/${sysconfdir}/lynis
install -m 555 ${S}/lynis ${D}/${bindir}
install -d ${D}/${datadir}/lynis/db
install -d ${D}/${datadir}/lynis/plugins
install -d ${D}/${datadir}/lynis/include
install -d ${D}/${datadir}/lynis/extras
cp -r ${S}/db/* ${D}/${datadir}/lynis/db/.
cp -r ${S}/plugins/* ${D}/${datadir}/lynis/plugins/.
cp -r ${S}/include/* ${D}/${datadir}/lynis/include/.
cp -r ${S}/extras/* ${D}/${datadir}/lynis/extras/.
cp ${S}/*.prf ${D}/${sysconfdir}/lynis
}
FILES:${PN} += "${sysconfdir}/developer.prf ${sysconfdir}/default.prf"
FILES:${PN}-doc += "lynis.8 FAQ README CHANGELOG.md CONTRIBUTIONS.md CONTRIBUTORS.md"
RDEPENDS:${PN} += "procps findutils"