blob: 764ca2862768c458855a3d9c73e1c8bfff924dcf [file] [log] [blame]
SUMMARY = "A library for property-based testing"
HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
LICENSE = "MPL-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
PYPI_PACKAGE = "hypothesis"
inherit pypi setuptools3 ptest
SRC_URI += " \
file://run-ptest \
file://test_binary_search.py \
file://test_rle.py \
"
SRC_URI[sha256sum] = "fa755ded526e50b7e2f642cdc5d64519f88d4e4ee71d9d29ec3eb2f2fddf1274"
RDEPENDS:${PN} += " \
python3-attrs \
python3-compression \
python3-core \
python3-json \
python3-pytest \
python3-sortedcontainers \
python3-statistics \
python3-unittest \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-unittest-automake-output \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/examples
install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/
install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/
}
BBCLASSEXTEND = "native nativesdk"