blob: 76ce58e58f8848999a13abd23e18da3c40ac1c63 [file] [log] [blame]
SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions"
HOMEPAGE = "https://github.com/nexB/license-expression"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRC_URI[sha256sum] = "599928edd995c43fc335e0af342076144dc71cb858afa1ed9c1c30c4e81794f5"
inherit pypi ptest python_setuptools_build_meta
DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
RDEPENDS:${PN} += "\
${PYTHON_PN}-booleanpy \
${PYTHON_PN}-core \
${PYTHON_PN}-json \
${PYTHON_PN}-stringold \
${PYTHON_PN}-logging \
"
BBCLASSEXTEND = "native nativesdk"
SRC_URI += " \
file://run-ptest \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
${PYTHON_PN}-unittest-automake-output \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
install -d ${D}${PTEST_PATH}/src
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
cp -rf ${S}/src/* ${D}${PTEST_PATH}/src/
cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
}