blob: fd02327f1cf63c01a860b342348b25c376f96a10 [file] [log] [blame]
FILESEXTRAPATHS_append := "${THISDIR}/files:"
inherit systemd
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
S = "${WORKDIR}/"
SRC_URI = "file://init_once.sh \
file://poweroff.sh \
file://poweron.sh \
file://host-gpio.service \
file://host-poweroff.service \
file://host-poweron.service"
DEPENDS = "systemd"
RDEPENDS_${PN} = "bash"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
do_install() {
install -d ${D}/usr/sbin
install -m 0755 ${S}init_once.sh ${D}/${sbindir}/
install -m 0755 ${S}poweroff.sh ${D}/${sbindir}/
install -m 0755 ${S}poweron.sh ${D}/${sbindir}/
}