blob: 40364960a1da06ace4d73da8d18f80f8f859a8e7 [file] [log] [blame]
SUMMARY = "OpenPower procedure control"
DESCRIPTION = "Provides procedures that run against the host chipset"
PR = "r1"
PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
S = "${WORKDIR}/git"
inherit autotools obmc-phosphor-utils pkgconfig pythonnative
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
SRCREV = "729521fef4fd2ab270fd0ebbc5035ad4ac7e5472"
DEPENDS += " \
autoconf-archive-native \
phosphor-logging \
phosphor-dbus-interfaces \
openpower-dbus-interfaces \
"
RDEPENDS_${PN} += " \
phosphor-logging \
phosphor-dbus-interfaces \
openpower-dbus-interfaces \
"
TEMPLATE = "pcie-poweroff@.service"
INSTANCE_FORMAT = "pcie-poweroff@{}.service"
INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}"