blob: 772a51462c9beda9181f89eb42908642450ec712 [file] [log] [blame]
SUMMARY = "OpenPower Hostboot Boot settings tool"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
inherit obmc-phosphor-systemd
inherit allarch
SRC_URI = "file://hb_settings"
SYSTEMD_SERVICE_${PN} += "hostboot-settings.service"
do_fetch[noexec] = "1"
do_patch[noexec] = "1"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/hb_settings ${D}${bindir}
}