| SUMMARY = "System load testing utility" |
| DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \ |
| imposes a configurable amount of CPU, memory, I/O, and disk stress on the system." |
| HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme" |
| LICENSE = "GPLv2" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| |
| SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https \ |
| file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \ |
| file://0001-Makefile-do-not-write-the-timestamp-into-compressed-.patch \ |
| " |
| SRCREV = "61b454b4a3a9d052e63c78a9574ccf8a650575dc" |
| S = "${WORKDIR}/git" |
| |
| DEPENDS = "coreutils-native" |
| |
| PROVIDES = "stress" |
| RPROVIDES:${PN} = "stress" |
| RREPLACES:${PN} = "stress" |
| RCONFLICTS:${PN} = "stress" |
| |
| inherit bash-completion |
| |
| do_install() { |
| oe_runmake DESTDIR=${D} install |
| ln -s stress-ng ${D}${bindir}/stress |
| } |