blob: 4cd3801ee703f95d392fa585a70cf3536a6bece6 [file] [log] [blame]
SUMMARY = "A fully featured modbus protocol stack in python"
HOMEPAGE = "https://github.com/riptideio/pymodbus/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=6a146397c35e3d0953758ce8803de347"
DEPENDS += "python3-six-native"
SRC_URI[sha256sum] = "26c1aa9919b24f2247794d5d9d80f65ec06fdfd9bd6b76b81d446b55335cabf3"
S = "${WORKDIR}/pymodbus-${PV}"
inherit pypi setuptools3
PACKAGECONFIG ??= ""
PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio"
PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio"
PACKAGECONFIG[tornado] = ",,,python3-tornado"
PACKAGECONFIG[twisted] = ",,,python3-twisted-conch"
PACKAGECONFIG[redis] = ",,,python3-redis"
PACKAGECONFIG[sql] = ",,,python3-sqlalchemy"
RDEPENDS:${PN} += " \
python3-asyncio \
python3-core \
python3-io \
python3-json \
python3-logging \
python3-math \
python3-netserver \
"
RDEPENDS:${PN} += " \
python3-pyserial \
python3-six \
"