blob: d1e763771850db71b53c17bd25d79a883a6cb3f2 [file] [log] [blame]
SUMMARY = "User DBUS object"
DESCRIPTION = "User DBUS object"
HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-user-mgmt
inherit obmc-phosphor-systemd
RDEPENDS_${PN} += "python-dbus python-pygobject python-pexpect"
SRC_URI += "git://github.com/openbmc/phosphor-networkd"
SRCREV = "cb3613575fd6fb18a7d2f7e7d86e7b6fd75f4269"
S = "${WORKDIR}/git"
INSTALL_NAME = "userman.py"
do_install() {
echo "***installing $INSTALL_NAME"
install -d ${D}/${sbindir}
install ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-userd
}