blob: fa616cd5044a6863b8ad05bca29fa8ec0dc45154 [file] [log] [blame]
SUMMARY = "Python documentation generator"
HOMEPAGE = "http://sphinx-doc.org/"
SECTION = "devel/python"
LICENSE = "BSD-2-Clause & MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb6ac1b115a1ed24a12d9f15b633993"
SRC_URI[sha256sum] = "59b8e391f0768a96cd233e8300fe7f0a8dc2f64f83dc2a54336a9a84f428ff4e"
inherit python_flit_core pypi
do_install:append () {
# The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
}
RDEPENDS:${PN} = "\
python3-alabaster \
python3-babel \
python3-docutils \
python3-imagesize \
python3-jinja2 \
python3-packaging \
python3-pygments \
python3-requests \
python3-snowballstemmer \
python3-sphinxcontrib-applehelp \
python3-sphinxcontrib-devhelp \
python3-sphinxcontrib-htmlhelp \
python3-sphinxcontrib-jsmath \
python3-sphinxcontrib-qthelp \
python3-sphinxcontrib-serializinghtml \
"
BBCLASSEXTEND = "native nativesdk"