blob: 556d79d33802d1873fe6dca3b1c66a332bcd5506 [file] [log] [blame]
SUMMARY = "OpenBMC - Applications"
PR = "r1"
inherit packagegroup
inherit obmc-phosphor-utils
inherit obmc-phosphor-license
PROVIDES = "${PACKAGES}"
PACKAGES = " \
${PN}-extras \
${PN}-extrasdev \
${PN}-inventory \
${PN}-leds \
${PN}-sensors \
${PN}-software \
"
SUMMARY_${PN}-extras = "Extra features"
RDEPENDS_${PN}-extras = " \
phosphor-rest \
"
SUMMARY_${PN}-extrasdev = "Development features"
RDEPENDS_${PN}-extrasdev = " \
rest-dbus \
"
SUMMARY_${PN}-inventory = "Inventory applications"
RDEPENDS_${PN}-inventory = " \
${VIRTUAL-RUNTIME_obmc-inventory-manager} \
"
SUMMARY_${PN}-leds = "LED applications"
RDEPENDS_${PN}-leds = " \
${VIRTUAL-RUNTIME_obmc-leds-manager} \
${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
"
SUMMARY_${PN}-sensors = "Sensor applications"
RDEPENDS_${PN}-sensors = " \
${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
"
SUMMARY_${PN}-software = "Software applications"
RDEPENDS_${PN}-software = " \
${VIRTUAL-RUNTIME_obmc-bmc-code-mgr} \
"