| SUMMARY = "Python bindings for GStreamer 1.0" |
| HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/" |
| SECTION = "multimedia" |
| |
| LICENSE = "LGPLv2.1" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740" |
| |
| SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz \ |
| file://0001-meson.build-fix-builds-with-python-3.8.patch \ |
| " |
| SRC_URI[md5sum] = "6ac709767334d8d0a71cb4e016f6abeb" |
| SRC_URI[sha256sum] = "208df3148d73d9f416d016564737585d8ea763d91201732d44b5fe688c6288a8" |
| |
| DEPENDS = "gstreamer1.0 python3-pygobject" |
| RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject" |
| |
| PNREAL = "gst-python" |
| |
| S = "${WORKDIR}/${PNREAL}-${PV}" |
| |
| # gobject-introspection is mandatory and cannot be configured |
| REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| UNKNOWN_CONFIGURE_WHITELIST_append = " introspection" |
| |
| inherit meson pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check |
| |
| do_install_append() { |
| |
| # Note that this particular find line is taken from the Debian packaging for |
| # gst-python1.0. |
| find "${D}" \ |
| -name '*.pyc' -o \ |
| -name '*.pyo' -o \ |
| -name '*.la' -o \ |
| -name 'libgstpythonplugin*' \ |
| -delete |
| } |