blob: 3eaec1e61f3291ea777b5a375c22b4d55076dfdf [file] [log] [blame]
SUMMARY = "Network DBUS object"
DESCRIPTION = "Network DBUS object"
HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
PR = "r1"
inherit autotools pkgconfig
inherit obmc-phosphor-license
inherit obmc-phosphor-dbus-service
DBUS_SERVICE_${PN} += "org.openbmc.NetworkManager.service"
SYSTEMD_SERVICE_${PN} += "network-update-dns.service"
DEPENDS += "autoconf-archive-native"
RDEPENDS_${PN} += "python-dbus python-pygobject python-ipy"
SRC_URI += "git://github.com/openbmc/phosphor-networkd"
SRCREV = "5e60ba5e76021ac901d808b264fad61db3ca3ae7"
S = "${WORKDIR}/git"
do_install_append() {
install -d ${D}/${sbindir}
install ${S}/netman.py ${D}/${sbindir}
}