blob: c0143718347684042f149faf1334af32bc9b783e [file] [log] [blame]
DESCRIPTION = "DNS toolkit for Python"
HOMEPAGE = "http://www.dnspython.org/"
LICENSE = "ISC"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34"
SRC_URI[sha256sum] = "233f871ff384d84c33b2eaf4358ffe7f8927eae3b257ad8467f9bdba7e7ac6bc"
inherit pypi python_hatchling ptest
SRC_URI += " \
file://run-ptest \
"
RDEPENDS:${PN}-ptest += " \
python3-pytest \
python3-unittest-automake-output \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
DEPENDS += "\
python3-wheel-native \
python3-setuptools-scm-native \
"
RDEPENDS:${PN} += " \
python3-crypt \
python3-io \
python3-math \
python3-netclient \
python3-numbers \
python3-threading \
"