blob: ce4671de9335013dae9853c08255a652d38f9bd2 [file] [log] [blame]
DESCRIPTION = "Python API for MISP"
HOMEPAGE = "https://github.com/MISP/PyMISP"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
SRC_URI[sha256sum] = "3ccdc6ee48d26d82c77ba3f5d8fd41a79eaaef0ad5619f37a65b060e92f6da4c"
inherit python_poetry_core pypi
PIP_INSTALL_PACKAGE = "pymisp"
RDEPENDS:${PN} += " \
python3-dateutil \
python3-json \
python3-jsonschema \
python3-requests \
python3-six \
python3-deprecated \
python3-wrapt \
"
# Fixes: python3-pymisp requires /bin/bash, but no
# providers found in RDEPENDS:python3-pymisp? [file-rdep]
RDEPENDS:${PN} += "bash"