blob: 57e979e909c3fea6b46a9f0ad8502c900c3fed15 [file] [log] [blame]
SUMMARY = "Simple powerful testing with python"
HOMEPAGE = "https://pypi.org/project/pytest/"
DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries."
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=bd27e41b6550fe0fc45356d1d81ee37c"
SRC_URI[sha256sum] = "d4051d623a2e0b7e51960ba963193b09ce6daeb9759a451844a21e4ddedfc1bd"
DEPENDS += "python3-setuptools-scm-native"
inherit update-alternatives pypi python_setuptools_build_meta
RDEPENDS:${PN} += " \
python3-atomicwrites \
python3-attrs \
python3-debugger \
python3-doctest \
python3-importlib-metadata \
python3-iniconfig \
python3-json \
python3-more-itertools \
python3-packaging \
python3-pathlib2 \
python3-pluggy \
python3-py \
python3-setuptools \
python3-six \
python3-tomllib \
python3-wcwidth \
"
ALTERNATIVE:${PN} += "py.test pytest"
NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
BBCLASSEXTEND = "native nativesdk"