blob: 13944ec780bdf8287d60eff3963eba3c0411debe [file] [log] [blame]
SUMMARY = "Physical quantities module"
DESCRIPTION = "Physical quantities Python module"
HOMEPAGE = "https://github.com/hgrecco/pint"
SECTION = "devel/python"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
PYPI_PACKAGE := "Pint"
inherit pypi ptest python_setuptools_build_meta
SRC_URI[sha256sum] = "3e98bdf01f4dcf840cc0207c0b6f7510d4e0c6288efc1bf470626e875c831172"
DEPENDS += "python3-setuptools-scm-native"
BBCLASSEXTEND = "native nativesdk"
SRC_URI += " \
file://run-ptest \
"
RDEPENDS:${PN} += " \
${PYTHON_PN}-setuptools \
${PYTHON_PN}-packaging \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/testsuite
cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
}