blob: 15bb00a3af417dfc8078919da0915b36c6bb37f0 [file] [log] [blame]
DESCRIPTION = "A sophisticated console ftp client"
HOMEPAGE = "http://ncftp.com/"
SECTION = "net"
LICENSE = "ClArtistic"
LIC_FILES_CHKSUM = "file://ncftp/cmds.c;beginline=3;endline=4;md5=9c2390809f71465aa7ff76e03dc14d91"
DEPENDS = "ncurses"
SRC_URI = "https://www.ncftp.com/public_ftp/ncftp/${BP}-src.tar.xz \
file://ncftp-configure-use-BUILD_CC-for-ccdv.patch \
file://unistd.patch \
file://0001-Forward-port-defining-PREFIX_BINDIR-to-use-new-autoc.patch \
"
SRC_URI[sha256sum] = "d41c5c4d6614a8eae2ed4e4d7ada6b6d3afcc9fb65a4ed9b8711344bef24f7e8"
inherit autotools-brokensep pkgconfig
CFLAGS += "-DNO_SSLv2 -D_FILE_OFFSET_BITS=64 -Wall"
PACKAGECONFIG ??= ""
PACKAGECONFIG[ccdv] = "--enable-ccdv,--disable-ccdv,,"
EXTRA_OECONF = "--disable-precomp --disable-universal ac_cv_path_TAR=tar"
ACLOCALEXTRAPATH:append = " -I ${S}/autoconf_local"
do_install () {
install -d ${D}${bindir} ${D}${sysconfdir} ${D}${mandir}
oe_runmake 'prefix=${D}${prefix}' 'BINDIR=${D}${bindir}' \
'SYSCONFDIR=${D}${sysconfdir}' 'mandir=${D}${mandir}' \
install
}