blob: a18b7017c9b95c79a454f6e06a59603ca87a37d7 [file] [log] [blame]
SUMMARY = "Phosphor Network IPMI Daemon"
DESCRIPTION = "Daemon to support IPMI protocol over network"
HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
PR = "r1"
PV = "1.0+git${SRCPV}"
inherit autotools pkgconfig
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
DEPENDS += "autoconf-archive-native"
DEPENDS += "phosphor-mapper"
DEPENDS += "systemd"
DEPENDS += "phosphor-ipmi-host"
RDEPENDS_${PN} += "libmapper"
RDEPENDS_${PN} += "libsystemd"
RDEPENDS_${PN} += "iptables"
inherit useradd
USERADD_PACKAGES = "${PN}"
# add ipmi group
GROUPADD_PARAM_${PN} = "ipmi"
SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
SRC_URI += "file://ipmi-net-firewall.sh"
SRCREV = "b00f8f7fdbe850ac6dc431713a10764031f5a0ec"
S = "${WORKDIR}/git"
do_install_append() {
install -m 0755 ${WORKDIR}/ipmi-net-firewall.sh \
${D}${sbindir}/ipmi-net-firewall.sh
}
SYSTEMD_SERVICE_${PN} = " \
${PN}.service \
${PN}.socket \
"