blob: 78730b46af5111d75dfe15a94a42413459726e5b [file] [log] [blame]
SUMMARY = "pandas library for high-performance data analysis tools"
DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
high-performance, easy-to-use data structures and data analysis tools for \
the Python programming language."
HOMEPAGE = "http://pandas.pydata.org/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c2a8f987b2ce77c368c6b3e1b5b10774"
SRC_URI[md5sum] = "594e6a429f297c77470e37d3510cccbb"
SRC_URI[sha256sum] = "a979d0404b135c63954dea79e6246c45dd45371a88631cdbb4877d844e6de3b6"
inherit pypi setuptools3
DEPENDS += " \
${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
"
CFLAGS_append_toolchain-clang = " -Wno-error=deprecated-declarations"
RDEPENDS_${PN} += " \
${PYTHON_PN}-json \
${PYTHON_PN}-numpy \
${PYTHON_PN}-dateutil \
${PYTHON_PN}-pytz \
"