| SUMMARY = "A partition editor to graphically manage disk partitions " |
| HOMEPAGE = "http://gparted.org/index.php" |
| LICENSE = "GPL-2.0-only" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| |
| inherit autotools pkgconfig python3native gnome-help gtk-icon-cache features_check |
| |
| ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
| |
| SRC_URI = " \ |
| ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \ |
| file://0001-Install-polkit-action-unconditionally-executable-pke.patch \ |
| file://0001-Do-not-use-NULL-where-boolean-is-expected.patch \ |
| file://0001-use-posix-basename.patch \ |
| " |
| SRC_URI[sha256sum] = "e5293a792e53fdbeba29c4a834113cd9603d0d639330da931a468bf3687887be" |
| |
| UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/gparted/files/gparted/" |
| UPSTREAM_CHECK_REGEX = "gparted-(?P<pver>\d+\.(\d+)+(\.\d+)+)" |
| |
| DEPENDS += " \ |
| glib-2.0-native \ |
| yelp-tools-native \ |
| intltool-native \ |
| glib-2.0 \ |
| gtkmm3 \ |
| parted \ |
| " |
| |
| FILES:${PN} += " \ |
| ${datadir}/appdata \ |
| ${datadir}/icons \ |
| " |
| |
| PACKAGES += "${PN}-polkit" |
| FILES:${PN}-polkit = "${datadir}/polkit-1" |
| |
| RDEPENDS:${PN} = " \ |
| ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', '${PN}-polkit', '', d)} \ |
| dosfstools \ |
| mtools \ |
| e2fsprogs \ |
| " |