| SUMMARY = "jQuery is a fast, small, and feature-rich JavaScript library" |
| HOMEPAGE = "https://jquery.com/" |
| LICENSE = "MIT" |
| SECTION = "devel" |
| LIC_FILES_CHKSUM = "file://${S}/${BP}.js;beginline=8;endline=10;md5=ebd7bc5d23ab165188e526a0c65d24bb" |
| |
| # unpack items to ${S} so the archiver can see them |
| # |
| SRC_URI = "\ |
| https://code.jquery.com/${BP}.js;name=js;subdir=${BP} \ |
| https://code.jquery.com/${BP}.min.js;name=min;subdir=${BP} \ |
| https://code.jquery.com/${BP}.min.map;name=map;subdir=${BP} \ |
| " |
| |
| SRC_URI[js.sha256sum] = "416a3b2c3bf16d64f6b5b6d0f7b079df2267614dd6847fc2f3271b4409233c37" |
| SRC_URI[min.sha256sum] = "f7f6a5894f1d19ddad6fa392b2ece2c5e578cbf7da4ea805b6885eb6985b6e3d" |
| SRC_URI[map.sha256sum] = "511d6f6d3e7acec78cd2505f04282b6e01329b4c24931f39d91739d0d1ddeef8" |
| |
| UPSTREAM_CHECK_REGEX = "jquery-(?P<pver>\d+(\.\d+)+)\.js" |
| |
| inherit allarch |
| |
| do_install() { |
| install -d ${D}${datadir}/javascript/${BPN}/ |
| install -m 644 ${S}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js |
| install -m 644 ${S}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js |
| install -m 644 ${S}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map |
| } |
| |
| PACKAGES = "${PN}" |
| FILES_${PN} = "${datadir}" |
| |
| BBCLASSEXTEND += "native nativesdk" |