| SUMMARY = "a fast C/C++ compiler cache" |
| DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \ |
| by caching the result of previous compilations and detecting when the \ |
| same compilation is being done again. Supported languages are C, C\+\+, \ |
| Objective-C and Objective-C++." |
| HOMEPAGE = "http://ccache.samba.org" |
| SECTION = "devel" |
| |
| LICENSE = "GPL-3.0-or-later" |
| LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=6a6fe0ae4e57592b187ab72fa6d420ec" |
| |
| DEPENDS = "zstd" |
| |
| SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \ |
| file://0001-xxhash.h-Fix-build-with-gcc-12.patch \ |
| " |
| SRC_URI[sha256sum] = "d59dd569ad2bbc826c0bc335c8ebd73e78ed0f2f40ba6b30069347e63585d9ef" |
| |
| inherit cmake github-releases |
| |
| PATCHTOOL = "patch" |
| |
| BBCLASSEXTEND = "native nativesdk" |
| |
| PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc" |
| PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis" |