| SUMMARY = "Tool to produce a statistics based on a diff" |
| DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \ |
| the insertions, deletions, and modifications per-file. It is useful for \ |
| reviewing large, complex patch files." |
| HOMEPAGE = "http://invisible-island.net/diffstat/" |
| SECTION = "devel" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5" |
| |
| SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \ |
| file://run-ptest \ |
| file://avoid-check-user-break-cc.patch \ |
| " |
| |
| SRC_URI[md5sum] = "91e106bb34cb097750db7ddc0ba1d8fc" |
| SRC_URI[sha256sum] = "7f09183644ed77a156b15346bbad4e89c93543e140add9dab18747e30522591f" |
| |
| S = "${WORKDIR}/diffstat-${PV}" |
| |
| inherit autotools gettext ptest |
| |
| EXTRA_AUTORECONF += "--exclude=aclocal" |
| |
| LDFLAGS += "${TOOLCHAIN_OPTIONS}" |
| |
| do_install_ptest() { |
| cp -r ${S}/testing ${D}${PTEST_PATH} |
| } |