| SUMMARY = "Python GObject bindings" |
| HOMEPAGE = "https://gitlab.gnome.org/GNOME/pygobject" |
| DESCRIPTION = "PyGObject is a Python package which provides bindings for GObject based libraries such as GTK, GStreamer, WebKitGTK, GLib, GIO and many more." |
| SECTION = "devel/python" |
| LICENSE = "LGPLv2.1" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| |
| GNOMEBASEBUILDCLASS = "meson" |
| inherit gnomebase distutils3-base upstream-version-is-even |
| |
| DEPENDS += "python3 glib-2.0" |
| |
| # Generating introspection data depends on a combination of native and target |
| # introspection tools, and qemu to run the target tools. |
| DEPENDS:append:class-target = " gobject-introspection gobject-introspection-native qemu-native prelink-native" |
| |
| # Even though introspection is disabled on -native, gobject-introspection package is still |
| # needed for m4 macros. |
| DEPENDS:append:class-native = " gobject-introspection-native" |
| DEPENDS:append:class-nativesdk = " gobject-introspection-native" |
| |
| SRCNAME="pygobject" |
| |
| SRC_URI = " \ |
| http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
| file://0001-Do-not-build-tests.patch \ |
| " |
| SRC_URI[sha256sum] = "9b12616e32cfc792f9dc841d9c472a41a35b85ba67d3a6eb427e307a6fe4367b" |
| |
| S = "${WORKDIR}/${SRCNAME}-${PV}" |
| |
| PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}" |
| |
| RDEPENDS:${PN} += "python3-pkgutil" |
| |
| # python3-pycairo is checked on configuration -> DEPENDS |
| # we don't link against python3-pycairo -> RDEPENDS |
| PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo" |
| |
| BBCLASSEXTEND = "native" |
| PACKAGECONFIG:class-native = "" |