| SUMMARY = "Python bindings for the DBus inter-process communication system" |
| SECTION = "devel/python" |
| HOMEPAGE = "http://www.freedesktop.org/Software/dbus" |
| LICENSE = "MIT & AFL-2.1 | GPLv2" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4 \ |
| file://dbus-gmain/COPYING;md5=05c3eacd50f69bb1d58afec460baad57 " |
| DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native" |
| |
| SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \ |
| " |
| |
| SRC_URI[md5sum] = "1ce1ddf2582060f8f971652ea54cc17e" |
| SRC_URI[sha256sum] = "32f29c17172cdb9cb61c68b1f1a71dfe7351506fc830869029c47449bd04faeb" |
| S = "${WORKDIR}/dbus-python-${PV}" |
| |
| inherit distutils-base autotools pkgconfig |
| |
| PACKAGECONFIG ?= "" |
| PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python3-docutils-native" |
| PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python3-docutils-native python3-epydoc-native" |
| |
| export STAGING_LIBDIR |
| export STAGING_INCDIR |
| |
| RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml" |
| |
| FILES_${PN}-dev += "${libdir}/pkgconfig" |
| |
| do_install_append() { |
| # Remove files that clash with python3-dbus; their content is same |
| rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc |
| } |