| SUMMARY = "Provides cryptographic recipes and primitives to python developers" |
| HOMEPAGE = "https://cryptography.io/" |
| SECTION = "devel/python" |
| LICENSE = "Apache-2.0 | BSD" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=097f805837700cfac572ac274cd38124" |
| |
| LDSHARED += "-pthread" |
| |
| SRC_URI[md5sum] = "1e476287399bae923514e19429804155" |
| SRC_URI[sha256sum] = "e4789b84f8dedf190148441f7c5bfe7244782d9cbb194a36e17b91e7d3e1cca9" |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| file://h-test.patch \ |
| " |
| |
| inherit pypi setuptools3 |
| |
| DEPENDS += " \ |
| ${PYTHON_PN}-cffi \ |
| ${PYTHON_PN}-cffi-native \ |
| ${PYTHON_PN}-asn1crypto \ |
| ${PYTHON_PN}-six \ |
| " |
| |
| RDEPENDS_${PN} += " \ |
| ${PYTHON_PN}-cffi \ |
| ${PYTHON_PN}-idna \ |
| ${PYTHON_PN}-asn1crypto \ |
| ${PYTHON_PN}-setuptools \ |
| ${PYTHON_PN}-six \ |
| " |
| |
| RDEPENDS_${PN}_class-target += " \ |
| ${PYTHON_PN}-cffi \ |
| ${PYTHON_PN}-idna \ |
| ${PYTHON_PN}-numbers \ |
| ${PYTHON_PN}-asn1crypto \ |
| ${PYTHON_PN}-setuptools \ |
| ${PYTHON_PN}-six \ |
| ${PYTHON_PN}-threading \ |
| " |
| |
| RDEPENDS_${PN}-ptest += " \ |
| ${PN} \ |
| ${PYTHON_PN}-cryptography-vectors \ |
| ${PYTHON_PN}-iso8601 \ |
| ${PYTHON_PN}-pretend \ |
| ${PYTHON_PN}-pytest \ |
| ${PYTHON_PN}-pytz \ |
| " |
| |
| inherit ptest |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| install -d ${D}${PTEST_PATH}/tests/hazmat |
| cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/ |
| } |
| |
| FILES_${PN}-dbg += " \ |
| ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \ |
| " |
| |
| BBCLASSEXTEND = "native nativesdk" |