blob: b3a8631794aef0a5fa5d2b5c9999af572ca4e9c9 [file] [log] [blame]
DESCRIPTION = "This is a simple example recipe that cross-compiles a Go program."
SECTION = "examples"
HOMEPAGE = "https://golang.org/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
SRC_URI = "git://go.googlesource.com/example;branch=master;protocol=https"
SRCREV = "787a929d5a0dfb8bbfcdd2c4a62e0fd89466113f"
UPSTREAM_CHECK_COMMITS = "1"
GO_IMPORT = "golang.org/x/example"
GO_INSTALL = "${GO_IMPORT}/hello"
GO_WORKDIR = "${GO_INSTALL}"
export GO111MODULE="off"
inherit go
# This is just to make clear where this example is
do_install:append() {
mv ${D}${bindir}/hello ${D}${bindir}/${BPN}
}