Customize inotify event initialization in UBI FS

Update core file inotify events on UBI FS based systems via a
compiler flag.

Change-Id: Id40b385d5b09d9fb6523694308e28d54ff53b78f
Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
index f6c098e..c29c16a 100644
--- a/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
+++ b/meta-phosphor/common/recipes-phosphor/dump/phosphor-debug-collector.bb
@@ -75,3 +75,10 @@
        install -m 0755 ${S}/tools/dreport \
                        ${D}${bindir}/dreport
 }
+
+#Enable ubifs-workaround by MACHINE_FEATURE obmc-ubi-fs.
+PACKAGECONFIG_append = "${@mf_enabled(d, 'obmc-ubi-fs', 'ubifs-workaround')}"
+PACKAGECONFIG[ubifs-workaround] = " \
+       --enable-ubifs-workaround, \
+       --disable-ubifs-workaround \
+"