blob: f6c098e1ee3eacf41782244cdc1793235bdc249b [file] [log] [blame]
Jayanth Othayoth9be81b12017-05-08 09:25:05 -05001SUMMARY = "Phosphor Debug Collector"
2DESCRIPTION = "Phosphor Debug Collector provides mechanisms \
Gunnar Millsdc81cf12017-08-08 10:53:28 -05003to collect various log files and system parameters. \
Jayanth Othayoth9be81b12017-05-08 09:25:05 -05004This will be helpful for troubleshooting the problems in OpenBMC \
5based systems."
6
7PR = "r1"
8
Jayanth Othayoth2a5d91e2017-05-31 06:25:55 -05009DEBUG_COLLECTOR_PKGS = " \
10 ${PN}-manager \
11 ${PN}-monitor \
Jayanth Othayothf4e66072017-07-29 22:28:44 -050012 ${PN}-dreport \
Jayanth Othayoth2a5d91e2017-05-31 06:25:55 -050013"
14PACKAGES =+ "${DEBUG_COLLECTOR_PKGS}"
15PACKAGES_remove = "${PN}"
16RDEPENDS_${PN}-dev = "${DEBUG_COLLECTOR_PKGS}"
17RDEPENDS_${PN}-staticdev = "${DEBUG_COLLECTOR_PKGS}"
18
19DBUS_PACKAGES = "${PN}-manager"
20
21SYSTEMD_PACKAGES = "${PN}-monitor"
22
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050023inherit autotools \
24 pkgconfig \
Jayanth Othayoth55c27902017-06-05 03:10:00 -050025 obmc-phosphor-dbus-service \
Jayanth Othayoth416458c2017-07-05 10:31:16 -050026 pythonnative \
27 phosphor-debug-collector
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050028
29require phosphor-debug-collector.inc
30
31DEPENDS += " \
32 phosphor-dbus-interfaces \
33 phosphor-dbus-interfaces-native \
34 phosphor-logging \
35 sdbusplus \
36 sdbusplus-native \
37 autoconf-archive-native \
Jayanth Othayoth2a5d91e2017-05-31 06:25:55 -050038"
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050039
Jayanth Othayoth2a5d91e2017-05-31 06:25:55 -050040RDEPENDS_${PN}-manager += " \
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050041 sdbusplus \
42 phosphor-dbus-interfaces \
43 phosphor-logging \
Jayanth Othayothf4e66072017-07-29 22:28:44 -050044 ${PN}-dreport \
Jayanth Othayoth2a5d91e2017-05-31 06:25:55 -050045"
46RDEPENDS_${PN}-monitor += " \
47 sdbusplus \
48 phosphor-dbus-interfaces \
49 phosphor-logging \
50"
Jayanth Othayothf4e66072017-07-29 22:28:44 -050051RDEPENDS_${PN}-dreport += " \
52 systemd \
53 ${VIRTUAL-RUNTIME_base-utils} \
54 bash \
Jayanth Othayothd3e04c62017-07-25 09:29:37 -050055 xz \
Jayanth Othayothf4e66072017-07-29 22:28:44 -050056"
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050057
Jayanth Othayoth416458c2017-07-05 10:31:16 -050058MGR_SVC ?= "xyz.openbmc_project.Dump.Manager.service"
59
60SYSTEMD_SUBSTITUTIONS += "BMC_DUMP_PATH:${bmc_dump_path}:${MGR_SVC}"
61
Jayanth Othayoth2a5d91e2017-05-31 06:25:55 -050062FILES_${PN}-manager += "${sbindir}/phosphor-dump-manager"
63FILES_${PN}-monitor += "${sbindir}/phosphor-dump-monitor"
Jayanth Othayothf4e66072017-07-29 22:28:44 -050064FILES_${PN}-dreport += "${bindir}/dreport"
Jayanth Othayoth2a5d91e2017-05-31 06:25:55 -050065
Jayanth Othayoth416458c2017-07-05 10:31:16 -050066DBUS_SERVICE_${PN}-manager += "${MGR_SVC}"
Jayanth Othayothc142e772017-09-15 10:55:35 -050067SYSTEMD_SERVICE_${PN}-monitor += "obmc-dump-monitor.service"
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050068
Jayanth Othayoth771b37b2017-07-05 10:54:35 -050069EXTRA_OECONF = "BMC_DUMP_PATH=${bmc_dump_path}"
Jayanth Othayoth416458c2017-07-05 10:31:16 -050070
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050071S = "${WORKDIR}/git"
Jayanth Othayothf4e66072017-07-29 22:28:44 -050072
73do_install_append() {
74 install -d ${D}${bindir}
75 install -m 0755 ${S}/tools/dreport \
76 ${D}${bindir}/dreport
77}