blob: 0c0c1251f272084bd98ab9f81a70a1c207ab83e7 [file] [log] [blame]
Jayanth Othayoth9be81b12017-05-08 09:25:05 -05001SUMMARY = "Phosphor Debug Collector"
2DESCRIPTION = "Phosphor Debug Collector provides mechanisms \
3to collect various FFDC files and system parameters. \
4This will be helpful for troubleshooting the problems in OpenBMC \
5based systems."
6
7PR = "r1"
8
9inherit autotools \
10 pkgconfig \
11 obmc-phosphor-dbus-service
12
13require phosphor-debug-collector.inc
14
15DEPENDS += " \
16 phosphor-dbus-interfaces \
17 phosphor-dbus-interfaces-native \
18 phosphor-logging \
19 sdbusplus \
20 sdbusplus-native \
21 autoconf-archive-native \
22 "
23
24RDEPENDS_${PN} += " \
25 sdbusplus \
26 phosphor-dbus-interfaces \
27 phosphor-logging \
28 "
29
30DBUS_SERVICE_${PN} += "xyz.openbmc_project.Dump.service"
31
32S = "${WORKDIR}/git"