| # This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org. |
| |
| SUMMARY = "Go programming language compiler (upstream binary for bootstrap)" |
| HOMEPAGE = " http://golang.org/" |
| LICENSE = "BSD-3-Clause" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707" |
| |
| PROVIDES = "go-native" |
| |
| # Checksums available at https://go.dev/dl/ |
| SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}" |
| SRC_URI[go_linux_amd64.sha256sum] = "d7ec48cde0d3d2be2c69203bc3e0a44de8660b9c09a6e85c4732a3f7dc442612" |
| SRC_URI[go_linux_arm64.sha256sum] = "aa2fab0a7da20213ff975fa7876a66d47b48351558d98851b87d1cfef4360d09" |
| SRC_URI[go_linux_ppc64le.sha256sum] = "049b8ab07d34077b90c0642138e10207f6db14bdd1743ea994a21e228f8ca53d" |
| |
| UPSTREAM_CHECK_URI = "https://golang.org/dl/" |
| UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux" |
| |
| CVE_PRODUCT = "go" |
| |
| S = "${WORKDIR}/go" |
| |
| inherit goarch native |
| |
| do_compile() { |
| : |
| } |
| |
| make_wrapper() { |
| rm -f ${D}${bindir}/$1 |
| cat <<END >${D}${bindir}/$1 |
| #!/bin/bash |
| here=\`dirname \$0\` |
| export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}" |
| \$here/../lib/go/bin/$1 "\$@" |
| END |
| chmod +x ${D}${bindir}/$1 |
| } |
| |
| do_install() { |
| find ${S} -depth -type d -name testdata -exec rm -rf {} + |
| |
| install -d ${D}${bindir} ${D}${libdir}/go |
| cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/ |
| |
| for f in ${S}/bin/* |
| do |
| make_wrapper `basename $f` |
| done |
| } |